close

[Fixed] Android Gradle plugin requires Java 11 to run. You are currently using Java 1.8

Today We are Going To Solve Android Gradle plugin requires Java 11 to run. You are currently using Java 1.8 in Java. Here we will Discuss All Possible Solutions and How this error Occurs So let’s get started with this Article.

How to Fix Android Gradle plugin requires Java 11 to run. You are currently using Java 1.8 Error?

  1. How to Fix Android Gradle plugin requires Java 11 to run. You are currently using Java 1.8 Error?

    To Fix Android Gradle plugin requires Java 11 to run. You are currently using Java 1.8 Error just Change JVM points to version 1.8 in . There are a few steps that will be useful o solve the error completely. So just try that: First of all change JVM points to version 1.8 in settings. And you can find it in preferences. Then Select Build, Execution, Deployment. And after it select build tools and Gradle. Then select Gradle JDK to 11. And your error will be solved. So just try these steps.

  2. Android Gradle plugin requires Java 11 to run. You are currently using Java 1.8

    To Fix Android Gradle plugin requires Java 11 to run. You are currently using Java 1.8 Error just Select JDK 16. To solve this error follow these steps:
    delete the folder for JDK 1.8 in your user folder and just restart your android studio.
    Then there is option asking if you wanted to change which JDK to use or redownload 1.8. Then just select JDK 16. It will help you.

Solution 1 : Change JVM points to version 1.8 in

There are a few steps that will be useful o solve the error completely. So just try that:

  1. First of all change JVM points to version 1.8 in settings. And you can find it in preferences.
  2. Then Select Build, Execution, Deployment.
  3. And after it select build tools and Gradle.
  4. Then select Gradle JDK to 11.

And your error will be solved. So just try these steps.

Solution 2 : Select JDK 16

To solve this error follow these steps:

  1. delete the folder for JDK 1.8 in your user folder and just restart your android studio.
  2. Then there is option asking if you wanted to change which JDK to use or redownload 1.8.
  3. Then just select JDK 16.

It will help you.

Conclusion

So these were all possible solutions to this error. I hope your error has been solved by this article. In the comments, tell us which solution worked? If you liked our article, please share it on your social media and comment on your suggestions. Thank you.

Also Read This Solutions

Leave a Comment