I am facing this problem hautelook/AliceBundle is gone in symfony

How this problem occurs ?

Something odd is happening to a well-known Symfony Framework bundle right now. I have no idea if there is a real-time channel I can ask about it, so I’m asking here, hoping somebody else noticed:

  1. I just had an error in my CI/CD pipeline caused by Composer package – apparently the Github repository https://github.com/hautelook/AliceBundle was briefly either taken private, or removed.
  2. About 10 minutes later, the repository re-appeared as https://github.com/theofidry/AliceBundle, this time as a fork of https://github.com/nowiko/AliceBundle

Solution 1

As Théo Fidry, the maintainer of that package, recommends: his Github account holds an up-to-date fork which can be used by adding the following settings to composer.json:

    "repositories": [
        {
            "type": "vcs",
            "url": "https://github.com/theofidry/AliceBundle"
        }
    ],

Solution 2

This might not be a direct answer to your question but I hope it might help people having huge troubles in their CI pipeline as I had. What I did to solve the issue because the version uploaded by theofidry required PHP 7.3 at least (and my old app does not meet this requirement) was:

  1. Go to your project folder in your local development
  2. Copy the folder vendor/hautelook/alice-bundle somewhere
  3. Run git init inside the copied folder
  4. Create a git repository (e.g on github) and push the content
  5. Back in your project, update your composer.json, change the version used for hautelook/alice-bundle to “dev-master” and add a vcs repository as specified below
  6. Run composer update and you should be fine

Adapt url accordingly:

"repositories": [
    {
        "type": "vcs",
        "url": "[email protected]:YourRepository/AliceBundle"
    }
]

That solution would work only if you had already a version of AliceBundle somewhere

  1. hautelook/AliceBundle is gone in symfony

    This might not be a direct answer to your question but I hope it might help people having huge troubles in their CI pipeline as I had. What I did to solve the issue because the version uploaded by theofidry required PHP 7.3 at least (and my old app does not meet this requirement) was:

  2. AliceBundle is gone in symfony

    This might not be a direct answer to your question but I hope it might help people having huge troubles in their CI pipeline as I had. What I did to solve the issue because the version uploaded by theofidry required PHP 7.3 at least (and my old app does not meet this requirement) was:

So here is all solution about hautelook/AliceBundle is gone in symfony

Also Read, Perl conditional (ternary) operator does no shortcut evaluation