close

[Fixed] Installed Build Tools revision 31.0.0 is corrupted. Remove and install again using the SDK Manager

Today We are Going To Solve Installed Build Tools revision 31.0.0 is corrupted. Remove and install again using the SDK Manager in Android Studio. Here we will Discuss All Possible Solutions and How this error Occurs So let’s get started with this Article.

How to Fix Installed Build Tools revision 31.0.0 is corrupted. Remove and install again using the SDK Manager Error?

  1. How to Fix Installed Build Tools revision 31.0.0 is corrupted. Remove and install again using the SDK Manager Error?

    To Fix Installed Build Tools revision 31.0.0 is corrupted. Remove and install again using the SDK Manager Error just For macOS. You have to just follow the below steps to remove your error: First of all Open the terminal application Type the command and press enter after every command line Just type cd /Users/admin/Library/Android/sdk/build-tools/. Here your user directory name may be different from “admin” keep in mind that thing. type cd 31.0.0 navigate this version. And at the last Type these things one by one : cp d8 dx then cd lib and at the last cp d8.jar dx.jar And your error will be removed.

  2. Installed Build Tools revision 31.0.0 is corrupted. Remove and install again using the SDK Manager

    To Fix Installed Build Tools revision 31.0.0 is corrupted. Remove and install again using the SDK Manager Error just Change the version. Here you have to just change the few lines and your problem will be solved. Lets learn this:
    First of all check the Project code panel, and go to Gradle Scripts → build.gradle file.
    And just change compileSdkVersionbuildToolsVersion, and targetSdkVersion from 31 to 30. When lightbulb hit occurring on modified lines You have to just click and choose sync. And you can see Android Studio will automatically download BuildTool V30 and change project settings. And just run the app. It will help you.

Solution 1 : For macOS

You have to just follow the below steps to remove your error:

  1. First of all Open the terminal application
  2. Type the command and press enter after every command line
  3. Just type cd /Users/admin/Library/Android/sdk/build-tools/. Here your user directory name may be different from “admin” keep in mind that thing.
  4. type cd 31.0.0 navigate this version.
  5. And at the last Type these things one by one : cp d8 dx then cd lib and at the last cp d8.jar dx.jar

And your error will be removed.

Solution 2 : Change the version

Here you have to just change the few lines and your problem will be solved. Lets learn this:

  1. First of all check the Project code panel, and go to Gradle Scripts → build.gradle file.
  2. And just change compileSdkVersionbuildToolsVersion, and targetSdkVersion from 31 to 30.
  3. When lightbulb hit occurring on modified lines You have to just click and choose sync. And you can see Android Studio will automatically download BuildTool V30 and change project settings.
  4. And just run the app.

It will help you.

Conclusion

So these were all possible solutions to this error. I hope your error has been solved by this article. In the comments, tell us which solution worked? If you liked our article, please share it on your social media and comment on your suggestions. Thank you.

Also Read these Solutions

Leave a Comment